ドキュメント

プロジェクトの作成

Aipo本体のチェックアウト、プロジェクト作成

  1. Eclipse を起動します。
  2. 「ウィンドウ」→「ビューの表示」→「その他」で「ビューの表示」を開きます。
  3. 「Git」→「Gitリポジトリー」を開きます。
  4. 「Gitリポジトリー」のビューより「Git リポジトリの複製」を選択します。
  5. 「URI」を選択し、ローケーションのURIに下記を入力します。
    https://github.com/aipocom/aipo.git
  6. 取得したいバージョンのソースコードをチェックし、次へ
  7. ディレクトリーを確認し、チェックアウトします。
    ※展開先は以下のディレクトリを推奨します。

    Windowsの場合

    C:\home\aipo\GitHub\aipo

    Macの場合

    ~/Documents/aipo/GitHub/aipo
  8. 「ファイル」→「インポート」→「Git」→「Gitからプロジェクト」を選択します。
  9. 「Existing local repository」から該当するプロジェクトを選択します。
  10. 作業ディレクトリを選択し、ラジオボタンは「既存プロジェクトのインポート」を選択してプロジェクトを作成します。

Aipo-Opensocialのチェックアウト、プロジェクト作成

  1. Aipo本体と同様の手順で「Gitリポジトリー」のビューより「Git リポジトリの複製」を選択します。
  2. 「URI」を選択し、ローケーションのURIに下記を入力します。
    https://github.com/aipocom/aipo-opensocial.git
  3. 取得したいバージョンのソースコードをチェックし、次へ
  4. ディレクトリーを確認し、チェックアウトします。
    ※展開先は以下のディレクトリを推奨します。

    Windowsの場合

    C:\home\aipo\GitHub\aipo-opensocial

    Macの場合

    ~/Documents/aipo/GitHub/aipo-opensocial
  5. 「ファイル」→「インポート」→「Git」→「Gitからプロジェクト」を選択します。
  6. 「Existing local repository」から該当するプロジェクトを選択します。
  7. 作業ディレクトリを選択し、ラジオボタンは「既存プロジェクトのインポート」を選択してプロジェクトを作成します。